Welcome to the new Filmotech Forum.
Old forums have been archived and are available here (read only)
To use this new forum, you need to create a new account.

AD
Where can I find th...
 
Notifications
Clear all

Where can I find the api.php compatible with PHP8.x

12 Posts
2 Users
0 Reactions
1,487 Views
0
Topic starter

Hello,

I am new to all this, and I need some help.

I installed the latest version of Filmotech (3.11.1) and publish the web version.

I install it on my server, using PHP8.x.

When I access it via my browser, I end up with the error "could not find driver"

After searching the web, I discover that the api.php may not be compatible with php8

I found a link to download a newer version that is suppose to work, but the link is not longer valid, it report error 404.

So where can I find the new API or do you have any other suggestion to resolve this issue.

Bye & thanks for the support in advance.

Jacques

Jacques Topic starter 17/04/2024 3:40 pm

I continue my search and find that the last version of Filmotech should be Ok for PHP V8.x
So that explain why I can't find the corrected api link.
Still I continue to received the same error what ever I tried.
"Erreur : could not find driver"
I can not figure out what driver can be missing or if the message is misleading.
I am trying to run the web application on Ubuntu 22.04.4 with apache2, PHP 8.1.2, sqlite 2.8.17 & sqlite3 3.37.2
Any help will be welcome.

Filmotech 17/04/2024 5:27 pm

@jacques Hello, the PHP script is using PDO object, so you need MySQL or SQLite php module for PDO.
Check in the PDO section of your phphinfo() for available module on your host.

Jacques Topic starter 17/04/2024 8:28 pm

Thanks, I did add the PDO extension.
Still not working but the error message change:
Erreur : SQLSTATE[HY000] [14] unable to open database file
I must have done something wrong.
Any suggestion??

Bye
Jacques

1 Answer
0
Topic starter

In the hope to help other fellow users, here some information regarding my experimentation with the publish function.

So to benefit English users, here some comments, since I move my posts on the subject to the French forum a few days back.

After some progress, I did not succeed publishing using 'mysql" mode. I did not find why, and stop searching.

The publish function was always end with an error; not been able to create the table in the database.

So I decide to install 'sqlite' on my server, and while the first installation did not work, I find how to make it work.

On my ubuntu server, i did this: sudo apt install php8.1-sqlite3

I also edit the 'php.ini' file to uncomment the line: extension=pdo_sqlite
Next I reboot to make sure I was all Ok.

I restart the publish function, but this time using 'sqlite' mode instead of 'mysql'

Note that you need to enter an access identifier, Filmotech 'api' need it, and all the others information must also be correctly input before launching the procedure.

Next you will have to copy the resulting files and directory to your web server.

Restart the publish function and this time it will work, at least it did for me.

Hope this help, and save you some time.

Bye

Jacques